[git pull] vfs pile 3/many...

From: Al Viro
Date: Tue Sep 10 2013 - 12:21:07 EST


Waiman's conversion of d_path() and bits related to it, kern_path_mountpoint(),
several cleanups and fixes (exportfs one is -stable fodder, IMO). There
definitely will be more... ;-/ Please, pull from the usual place -
git://git.kernel.org/pub/scm/linux/kernel/git/viro/vfs.git for-linus

Shortlog:
Al Viro (8):
afs: get rid of redundant ->d_name.len checks
exportfs: don't assume that ->iterate() won't feed us too long entries
prune_super(): sb->s_op is never NULL
Kill indirect include of file.h from eventfd.h, use fdget() in cgroup.c
take unlazy_walk() into umount_lookup_last()
rename user_path_umountat() to user_path_mountpoint_at()
introduce kern_path_mountpoint()
split read_seqretry_or_unlock(), convert d_walk() to resulting primitives

Ian Kent (1):
autofs4 - fix device ioctl mount lookup

Waiman Long (1):
dcache: Translating dentry into pathname without taking rename_lock

Diffstat:
fs/afs/dir.c | 24 -----
fs/autofs4/dev-ioctl.c | 23 +++---
fs/dcache.c | 220 +++++++++++++++++++++++++++++++----------------
fs/exportfs/expfs.c | 2 +-
fs/internal.h | 3 +
fs/namei.c | 112 +++++++++++++-----------
fs/namespace.c | 2 +-
fs/super.c | 2 +-
include/linux/eventfd.h | 3 +-
include/linux/namei.h | 4 +-
kernel/cgroup.c | 33 ++++----
11 files changed, 241 insertions(+), 187 deletions(-)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/