[RFC][PATCH] genirq: add IRQF_NONE

From: Michael Opdenacker
Date: Sun Sep 08 2013 - 23:49:06 EST


What about adding an IRQF_NONE flag as in the below patch?

I'm currently working on removing the use of the deprecated
IRQF_DISABLED flag, and frequently have to replace
IRQF_DISABLED by 0, typically in request_irq() arguments.

Using IRQF_NONE instead of 0 would make the code more readable,
at least for people reading driver code for the first time.

Would it worth it?

I'm sure this kind of idea has come up many times before...

Signed-off-by: Michael Opdenacker <michael.opdenacker@xxxxxxxxxxxxxxxxxx>
---
include/linux/interrupt.h | 2 ++
1 file changed, 2 insertions(+)

diff --git a/include/linux/interrupt.h b/include/linux/interrupt.h
index 5fa5afe..e289525 100644
--- a/include/linux/interrupt.h
+++ b/include/linux/interrupt.h
@@ -40,6 +40,7 @@
* These flags used only by the kernel as part of the
* irq handling routines.
*
+ * IRQF_NONE - No irq flag bit is set.
* IRQF_DISABLED - keep irqs disabled when calling the action handler.
* DEPRECATED. This flag is a NOOP and scheduled to be removed
* IRQF_SHARED - allow sharing the irq among several devices
@@ -59,6 +60,7 @@
* IRQF_EARLY_RESUME - Resume IRQ early during syscore instead of at device
* resume time.
*/
+#define IRQF_NONE 0x00000000
#define IRQF_DISABLED 0x00000020
#define IRQF_SHARED 0x00000080
#define IRQF_PROBE_SHARED 0x00000100
--
1.8.1.2

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/