Re: OPP: rename functions? (was [PATCH] OPP: Export opp_add())

From: Nishanth Menon
Date: Thu Aug 08 2013 - 08:00:48 EST

On 08/07/2013 05:53 PM, Rafael J. Wysocki wrote:
On Wednesday, August 07, 2013 10:48:54 AM Nishanth Menon wrote:
offline question:

Not really offline. :-)


On 08/06/2013 09:15 AM, Rafael J. Wysocki wrote:
On Tuesday, August 06, 2013 08:08:20 AM Nishanth Menon wrote:
change in subject to reflect new discussion.

On 05:53-20130806, Randy Dunlap wrote:
On 08/03/2013 02:25 AM, Viresh Kumar wrote:


Could it be renamed to pm_opp_add() or power_opp_add() ?
The name is a bit too unspecific IMO.
Though this has nothing specific with this patch, an interesting point.

git grep -w opp . showed drivers/tty/n_tty.c,
drivers/sbus/char/openprom.c and arch/powerpc/kvm/mpic.c using
variables named opp to mean what ever they had in context. rest(around
40 odd files) seem to use opp as in Documentation/power/opp.txt..

We could go with a pm_ prefix or even dev_pm_opp_ prefix to be more
specific, though I prefer just pm_. If Rafael and others are ok, I can
post a series out.

Yup, that would be useful. I'm for dev_pm_opp_ if that matters.

Given that there would be quiet a few conflicts, do you have a
suggestion around what baseline I should submit this?

Well, ideally, on top of 3.12-rc1 when it's out and put it into linux-next
right after that.

Will do. Thanks on the hint.

Nishanth Menon
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at