Re: [PATCH 0/5] ACPI: acpi_bind_one()/acpi_unbind_one() cleanups

From: Toshi Kani
Date: Tue Aug 06 2013 - 17:16:49 EST

On Tue, 2013-08-06 at 02:22 +0200, Rafael J. Wysocki wrote:
> Hi All,
> The following 5 patches clean up a little mess in acpi_bind_one() and
> acpi_unbind_one(). They are on top of current linux-next plus the patch
> at .
> [1/5] Move duplicated code from acpi_bind_one()/acpi_unbind_one() to a separate
> function.

I think the name of acpi_bind_physnode_name() is a bit confusing as if
it would make some persistent binding. So, I'd suggest to rename it to

> [2/5] Create symlinks in acpi_bind_one() under physical_node_lock.
> [3/5] Clean up inconsistent use of whitespace in acpi_bind_one()/acpi_unbind_one().
> [4/5] Use list_for_each_entry() to walk the list in acpi_unbind_one().
> [5/5] Clean up the error code path in acpi_unbind_one().

All changes look good. For the series:

Acked-by: Toshi Kani <toshi.kani@xxxxxx>


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at