Re: [PATCH v2 2/2] tracing: Shrink the size of structftrace_event_field

From: Steven Rostedt
Date: Sat Jul 27 2013 - 07:35:49 EST


On Sat, 2013-07-27 at 10:45 +0200, Borislav Petkov wrote:
>
> > > + field->filter_type = filter_type;
> > > field->offset = offset;
> > > field->size = size;
> > > - field->is_signed = is_signed;
> > > + field->is_signed = !!is_signed;
> > > +
> > > + VERIFY_SIZE(filter_type);
> > > + VERIFY_SIZE(offset);
> > > + VERIFY_SIZE(size);
>
> Isn't this wrap-a-macro-with-another-more-obscure-macro not a bit too
> much?
>
> I mean,
> WARN_ON(filter_type > field->filter_type)
>
> is much more readable than VERIFY_SIZE IMO.

Fair enough. My first version of the test was a bit more complex, and
then I simplified it, but kept the macro. Either is fine to me. But
yeah, I can see the point that the test isn't that complex, and there's
only three tests. If there were more or the test a bit more complex,
then I would definitely want the macro.

But you know me. I LOVE macros!

-- Steve


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/