Re: [PATCH v2 03/14] perf: Add persistent event facilities

From: Peter Zijlstra
Date: Tue Jun 25 2013 - 03:44:20 EST


On Mon, Jun 24, 2013 at 09:26:16PM +0200, Borislav Petkov wrote:
> On Mon, Jun 24, 2013 at 11:48:30AM +0200, Peter Zijlstra wrote:
> > On Tue, Jun 11, 2013 at 06:42:29PM +0200, Robert Richter wrote:
> > > +int perf_add_persistent_event_by_id(int id)
> > > +{
> > > + struct perf_event_attr *attr;
> > > +
> > > + attr = kzalloc(sizeof(*attr), GFP_KERNEL);
> > > + if (!attr)
> > > + return -ENOMEM;
> > > +
> > > + attr->sample_period = 1;
> > > + attr->wakeup_events = 1;
> > > + attr->sample_type = PERF_SAMPLE_RAW;
> > > + attr->persistent = 1;
> > > + attr->config = id;
> > > + attr->type = PERF_TYPE_TRACEPOINT;
> > > + attr->size = sizeof(*attr);
> > > +
> > > + return perf_add_persistent_event(attr, CPU_BUFFER_NR_PAGES);
> > > +}
> >
> > I would call this what it is: perf_add_persistent_tracepoint(), or so
> > :-)
>
> While we're at it, can we agree on a shortened variant for "persistent"
> - it is too much to type and makes function names uglily¹ long.

Elsewhere in this series you use 'pers' to shorten things; it reads a
bit odd to me because 'pers' is the Dutch word for press (both meanings
transfer) but that is just something I'll have to live with isn't it ;-)

As for tracepoint, it seems common to shorten that to tp; which always
reminds me of toilet paper, but I suppose more people suffer from that.

Yielding: perf_add_pers_tp()

which I read as adding pressed toilet paper.. a well :-)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/