Re: [PATCHv12 3/4] zswap: add to mm/

From: Andrew Morton
Date: Wed May 29 2013 - 15:57:59 EST


On Wed, 29 May 2013 14:50:27 -0500 Seth Jennings <sjenning@xxxxxxxxxxxxxxxxxx> wrote:

> On Wed, May 29, 2013 at 11:29:29AM -0700, Andrew Morton wrote:
> > On Wed, 29 May 2013 09:57:20 -0500 Seth Jennings <sjenning@xxxxxxxxxxxxxxxxxx> wrote:
> >
> > > > > +/*********************************
> > > > > +* helpers
> > > > > +**********************************/
> > > > > +static inline bool zswap_is_full(void)
> > > > > +{
> > > > > + return (totalram_pages * zswap_max_pool_percent / 100 <
> > > > > + zswap_pool_pages);
> > > > > +}
> > > >
> > > > We have had issues in the past where percentage-based tunables were too
> > > > coarse on very large machines. For example, a terabyte machine where 0
> > > > bytes is too small and 10GB is too large.
> > >
> > > Yes, this is known limitation of the code right now and it is a high priority
> > > to come up with something better. It isn't clear what dynamic sizing policy
> > > should be used so, until such time as that policy can be determined, this is a
> > > simple stop-gap that works well enough for simple setups.
> >
> > It's a module parameter and hence is part of the userspace interface.
> > It's undesirable that the interface be changed, and it would be rather
> > dumb to merge it as-is when we *know* that it will be changed.
> >
> > I don't think we can remove the parameter altogether (or can we?), so I
> > suggest we finalise it ASAP. Perhaps rename it to
> > zswap_max_pool_ratio, with a range 1..999999. Better ideas needed :(
>
> zswap_max_pool_ratio is fine with me. I'm not entirely clear on the change
> though. Would that just be a name change or a change in meaning?

It would be a change in behaviour. The problem which I'm suggesting we
address is that a 1% increment is too coarse.

> Also, we can keep the tunable as I imagine there will always be some use for a
> manual override of the (future) dynamic policy. When the dynamic policy is
> available, we can just say that zswap_max_pool_ratio = 0 means "use dynamic
> policy" and change the default to 0. Does that sounds reasonable?

Sounds OK.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/