Re: [RFC PATCH 02/02] swapon: add "cluster-discard" support

From: KOSAKI Motohiro
Date: Tue May 21 2013 - 18:02:07 EST

> Instead of reverting and renaming --discard, what about making it accept an
> optional argument, so we could use --discard (to enable all thing and keep
> backward compatibility); --discard=cluster & --discard=batch (or whatever we
> think it should be named). I'll try to sort this approach out if you folks think
> it's worthwhile.

Optional argument looks nice, at least to me.

But hmm..

"cluster" and "batch" describes current kernel implementation, not user visible effect.
Usually I suggest to pick up a word from man pages because it describe user visible action.
e.g. --discard=freed-pages or --discard=io or --discard=swapon or --discard=once, etc..

But this is not strong opinion. You can ignore it. I don't think I have good English sense. :-)

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at