Re: [PATCH 5/5] drivers: net: usb: rtl8150: making the code a bitbetter looking

From: Petko Manolov
Date: Mon May 20 2013 - 15:16:50 EST


On Mon, 20 May 2013, Ben Hutchings wrote:

> [...]
> > @@ -771,12 +770,12 @@ static void rtl8150_disconnect(struct usb_interface *intf)
> > }
> >
> > static struct usb_driver rtl8150_driver = {
> > - .name = driver_name,
> > - .probe = rtl8150_probe,
> > - .disconnect = rtl8150_disconnect,
> > - .id_table = rtl8150_table,
> > - .suspend = rtl8150_suspend,
> > - .resume = rtl8150_resume,
> > + .name = driver_name,
> > + .probe = rtl8150_probe,
> > + .disconnect = rtl8150_disconnect,
> > + .id_table = rtl8150_table,
> > + .suspend = rtl8150_suspend,
> > + .resume = rtl8150_resume,
> > .disable_hub_initiated_lpm = 1,
> > };
>
> These looked better before. Lining up initialisers in a structure
> definition is good style.

It is. This is what i usually do. However, scripts/Lindent is messed up
in (not only) this regard. IMHO it should not be used as it is.

I thought using what is recommended (at least in the documentation) makes
me a good citizen even though i don't like the end result much.

Again, the above is true in case i've not misunderstood something,
somewhere.


Petko
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/