Re: [PATCHv2] virtio_pci: better macro exported in uapi

From: Rusty Russell
Date: Sun May 19 2013 - 22:36:38 EST


"Michael S. Tsirkin" <mst@xxxxxxxxxx> writes:

> Macro VIRTIO_PCI_CONFIG assumes that userspace actually has a structure
> with a field named msix_enabled. Add VIRTIO_PCI_CONFIG_OFF that gets
> the msix_enabled by value instead, to make it useful for userspace. We
> still keep VIRTIO_PCI_CONFIG around for now, in case some userspace uses
> it.
>
> Signed-off-by: Michael S. Tsirkin <mst@xxxxxxxxxx>

Applied.

Thanks,
Rusty.

> ---
>
> Changes from v1:
> - rename macro to VIRTIO_PCI_CONFIG_OFF so preprocessor
> can be used to check for its presence, as suggested
> by Rusty
> - keep old macro around as suggested by David Howells
>
> include/uapi/linux/virtio_pci.h | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/include/uapi/linux/virtio_pci.h b/include/uapi/linux/virtio_pci.h
> index ea66f3f..e5ec1ca 100644
> --- a/include/uapi/linux/virtio_pci.h
> +++ b/include/uapi/linux/virtio_pci.h
> @@ -80,7 +80,9 @@
>
> /* The remaining space is defined by each driver as the per-driver
> * configuration space */
> -#define VIRTIO_PCI_CONFIG(dev) ((dev)->msix_enabled ? 24 : 20)
> +#define VIRTIO_PCI_CONFIG_OFF(msix_enabled) ((msix_enabled) ? 24 : 20)
> +/* Deprecated: please use VIRTIO_PCI_CONFIG_OFF instead */
> +#define VIRTIO_PCI_CONFIG(dev) VIRTIO_PCI_CONFIG_OFF((dev)->msix_enabled)
>
> /* Virtio ABI version, this must match exactly */
> #define VIRTIO_PCI_ABI_VERSION 0
> --
> MST
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/