Re: [RFC PATCH 0/2] return value from shrinkers

From: Andrew Morton
Date: Thu May 16 2013 - 12:27:57 EST

On Thu, 16 May 2013 09:52:05 +0200 Oskar Andero <oskar.andero@xxxxxxxxxxxxxx> wrote:

> > If we want the capability to return more than a binary yes/no message
> > to callers then yes, we could/should enumerate the shrinker return
> > values. But as that is a different concept from errnos, it should be
> > done with a different and shrinker-specific namespace.
> Agreed, but even if there right now is only a binary return message, is a
> hardcoded -1 considered to be acceptable for an interface? IMHO, it is not
> very readable nor intuitive for the users of the interface. Why not, as you
> mention, add a define or enum in shrinker.h instead, e.g. SHRINKER_STOP or
> something.

That sounds OK to me.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at