Re: [PATCH v5 01/11] mtd: add datasheet's ECC information to nand_chip{}

From: Huang Shijie
Date: Thu May 16 2013 - 04:07:16 EST

ä 2013å05æ16æ 15:14, Artem Bityutskiy åé:
On Thu, 2013-05-16 at 10:16 +0800, Huang Shijie wrote:
ä 2013å05æ15æ 20:11, Artem Bityutskiy åé:
On Wed, 2013-05-15 at 16:40 +0800, Huang Shijie wrote:
+ * @ecc_strength: [INTERN] ECC correctability from the datasheet.
+ * Minimum amount of bit errors per @ecc_step guaranteed to
+ * be correctable. If unknown, set to zero.
+ * @ecc_step: [INTERN] ECC step required by the @ecc_strength,
+ * also from the datasheet. It is the recommended ECC step
+ * size, if known; if unknown, set to zero.
Here and in other places you talk about "datasheet". Do you assume that
the real ECC strength/step used by NAND chips may be different? Or you
assume it must be the same?

The two fields are used to store the ecc info from the datasheet.
The two fields are just for a reference.

[1] The nand controller may do not use these two fields, it's ok;
For example, the datasheet requires "4bits per 512 bytes".
The nand controller can uses 8bits per 512 bytes.

[2] but sometimes the nand controller must use these two fields.
For example, the datasheet requires "40bits per 1024 bytes".
For the hardware limit, the nand controller(BCH) may supports the
40bits ecc in the maximum.
So the nand controller must use these two fields now.
I wonder if it makes sense to name things so that it is clear form the
names whether that is the "theoretical" datasheet values or the real
ones. I would prefer to clearly distinguish between them, in names and
comments. Thoughts?

what's about add the "_datasheet" for these two fields?
such as


Huang Shijie

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at