[PATCH 0/9] Convert all to the caller hold lock version

From: Wang YanQing
Date: Wed May 08 2013 - 14:13:22 EST


After commit 50e244cc793d511b86adea24972f3a7264cae114
(fb: rework locking to fix lock ordering on takeover)
and
commit e93a9a868792ad71cdd09d75e5a02d8067473c4e
(fb: Yet another band-aid for fixing lockdep mess)

We have two version functions implement almost the same function,
except the caller/callee hold lock.

fbcon_takeover vs do_fbcon_takeover
register_con_driver vs do_register_con_driver
take_over_console vs do_take_over_console
unbind_con_driver vs do_unbind_con_driver
bind_con_driver vs do_bind_con_driver
unregister_con_driver vs do_unregister_con_driver

This issue bring us much code duplication,
like do_fbcon_takeover and fbcon_takeover,
they have almost the same.

Although some of them had been re-written
as a wrapper for another, but the wrapper
is so trivial, we can just throw them away.

Also those two versions of almost the same
functions will confuse API's user.

After all, I think this issue is not good
for long time maintain.

This series patch convert all to the
new version which caller hold the lock,
and then delete the old version away.

Thanks


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/