Re: [PATCH v5 1/3] arm: introduce psci_smp_ops

From: Will Deacon
Date: Tue Apr 02 2013 - 12:47:11 EST


On Tue, Apr 02, 2013 at 05:16:12PM +0100, Stefano Stabellini wrote:
> Rename virt_smp_ops to psci_smp_ops and move them to arch/arm/kernel/psci_smp.c.
> Remove mach-virt/platsmp.c, now unused.
> Compile psci_smp if CONFIG_ARM_PSCI and CONFIG_SMP.
>
> Add a cpu_die smp_op based on psci_ops.cpu_off.
>
> Initialize PSCI before setting smp_ops in setup_arch.
> Use psci_smp_ops if the platform doesn't provide its own smp_ops.
>
>
> Changes in v5:
> - document psci_operations;
> - psci_init returns NULL.
>
>
> Signed-off-by: Stefano Stabellini <stefano.stabellini@xxxxxxxxxxxxx>
> Acked-by: Nicolas Pitre <nico@xxxxxxxxxx>
> Acked-by: Rob Herring <rob.herring@xxxxxxxxxxx>
>
> CC: will.deacon@xxxxxxx
> CC: arnd@xxxxxxxx
> CC: marc.zyngier@xxxxxxx
> CC: linux@xxxxxxxxxxxxxxxx
> CC: nico@xxxxxxxxxx
> ---
> arch/arm/include/asm/psci.h | 29 ++++++++++++++++++
> arch/arm/kernel/Makefile | 5 ++-
> arch/arm/kernel/psci.c | 7 ++--
> arch/arm/kernel/psci_smp.c | 67 ++++++++++++++++++++++++++++++++++++++++++
> arch/arm/kernel/setup.c | 7 ++++-
> arch/arm/mach-virt/Makefile | 1 -
> arch/arm/mach-virt/platsmp.c | 58 ------------------------------------
> arch/arm/mach-virt/virt.c | 3 --
> 8 files changed, 109 insertions(+), 68 deletions(-)
> create mode 100644 arch/arm/kernel/psci_smp.c
> delete mode 100644 arch/arm/mach-virt/platsmp.c

Reviewed-by: Will Deacon <will.deacon@xxxxxxx>

Will
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/