Re: [PATCH] pwm: pxa: Use driver_data field to store pwm_nr

From: Axel Lin
Date: Mon Apr 01 2013 - 03:34:19 EST


2013/4/1 Eric Miao <eric.y.miao@xxxxxxxxx>:
> On Mon, Apr 1, 2013 at 12:12 AM, Axel Lin <axel.lin@xxxxxxxxxx> wrote:
>> The driver_data field was used to store information about PWM_ID_BASE and
>> HAS_SECONDARY_PWM. PWM_ID_BASE is not used now after convert to pwm framework.
>> This patch stores the pwm_nr in driver_data field to simplify the code.
>>
>> Signed-off-by: Axel Lin <axel.lin@xxxxxxxxxx>
>> ---
>> drivers/pwm/pwm-pxa.c | 11 ++++-------
>> 1 file changed, 4 insertions(+), 7 deletions(-)
>>
>> diff --git a/drivers/pwm/pwm-pxa.c b/drivers/pwm/pwm-pxa.c
>> index b789882..019a8e0 100644
>> --- a/drivers/pwm/pwm-pxa.c
>> +++ b/drivers/pwm/pwm-pxa.c
>> @@ -22,13 +22,10 @@
>>
>> #include <asm/div64.h>
>>
>> -#define HAS_SECONDARY_PWM 0x10
>> -#define PWM_ID_BASE(d) ((d) & 0xf)
>> -
>> static const struct platform_device_id pwm_id_table[] = {
>> - /* PWM has_secondary_pwm? */
>> - { "pxa25x-pwm", 0 },
>> - { "pxa27x-pwm", 0 | HAS_SECONDARY_PWM },
>> + /* PWM pwm_nr */
>> + { "pxa25x-pwm", 1 },
>> + { "pxa27x-pwm", 2 },
>> { "pxa168-pwm", 1 },
>> { "pxa910-pwm", 1 },
>> { },
>> @@ -145,7 +142,7 @@ static int pwm_probe(struct platform_device *pdev)
>> pwm->chip.dev = &pdev->dev;
>> pwm->chip.ops = &pxa_pwm_ops;
>> pwm->chip.base = -1;
>> - pwm->chip.npwm = (id->driver_data & HAS_SECONDARY_PWM) ? 2 : 1;
>> + pwm->chip.npwm = id->driver_data;
>
> I'd rather keep the flag for a bit more readability?

Well, I'd send a patch to just remove PWM_ID_BASE which is not used now.

Regards,
Axel
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/