[PATCH 00/11] thermal: clean ups on thermal code base

From: Eduardo Valentin
Date: Fri Mar 22 2013 - 17:01:38 EST


Hey Rui,


Here is a sequence of fixes and documentation improvements
thermal code base. This should be first of a series of changes
I am planing to send out.

On this very first there is no change in functionality, as
the patches only change symbol names and updates kernel-doc
comments and their formants.



For those interested in testing and trying the driver, these patches are
also available, as usual, here:
git@xxxxxxxxxxxxx:thermal-framework/thermal-framework.git thermal_work/thermal_fw/coding_style
https://git.gitorious.org/thermal-framework/thermal-framework.git thermal_work/thermal_fw/coding_style

Eduardo Valentin (11):
thermal: use strlcpy instead of strcpy
thermal: update driver license
thermal: rename notify_thermal_framework to thermal_notify_framework
thermal: rename get_thermal_instance to thermal_instance_get
thermal: rename get_tz_trend to thermal_zone_trend_get
thermal: use EXPORT_SYMBOL_GPL
thermal: update kernel-doc for thermal_zone_bind_cooling_device
thermal: update kernel-doc for thermal_zone_unbind_cooling_device
thermal: update kernel-doc for thermal_cooling_device_register
thermal: update kernel-doc for create_trip_attrs
thermal: update kernel-doc for thermal_zone_device_register

Documentation/thermal/sysfs-api.txt | 6 +-
drivers/thermal/fair_share.c | 2 +-
drivers/thermal/step_wise.c | 2 +-
drivers/thermal/thermal_sys.c | 90 ++++++++++++++++++++++++-----------
include/linux/thermal.h | 6 +-
5 files changed, 70 insertions(+), 36 deletions(-)

--
1.7.7.1.488.ge8e1c

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/