Re: [PATCH] sched: wakeup buddy

From: Michael Wang
Date: Thu Mar 07 2013 - 21:34:04 EST


On 03/08/2013 01:21 AM, Peter Zijlstra wrote:
> On Wed, 2013-03-06 at 15:06 +0800, Michael Wang wrote:
>> +static inline int wakeup_related(struct task_struct *p)
>> +{
>> + if (wakeup_buddy(p, current)) {
>> + /*
>> + * Now check whether current still focus on his buddy.
>> + */
>> + if (wakeup_buddy(current, p))
>> + return 1;
>> + }
>> +
>> + return 0;
>> +}
>
> Not commenting on the thing in general, but:
>
> static inline bool wakeup_related(struct task_struct *p)
> {
> return wakeup_buddy(p, current) && wakeup_buddy(current, p);
> }
>
> is far shorter and easier to read :-)

Right, I will correct it :)

Regards,
Michael Wang

>

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/