Re: [PATCH] gpio: viperboard: Remove duplicate code to set gpio->gpiob_val

From: Lars Poeschel
Date: Wed Mar 06 2013 - 05:38:21 EST


On Tuesday 05 March 2013 at 13:21:56, Axel Lin wrote:
> Set it once is enough, and it's done in vprbrd_gpiob_set() which is called
> by vprbrd_gpiob_direction_output().
>
> Signed-off-by: Axel Lin <axel.lin@xxxxxxxxxx>

Thank you!

Tested-and-Acked-by: Lars Poeschel <poeschel@xxxxxxxxxxx>

> ---
> drivers/gpio/gpio-viperboard.c | 4 ----
> 1 file changed, 4 deletions(-)
>
> diff --git a/drivers/gpio/gpio-viperboard.c
> b/drivers/gpio/gpio-viperboard.c index 59d7239..095ab14 100644
> --- a/drivers/gpio/gpio-viperboard.c
> +++ b/drivers/gpio/gpio-viperboard.c
> @@ -380,10 +380,6 @@ static int vprbrd_gpiob_direction_output(struct
> gpio_chip *chip, struct vprbrd *vb = gpio->vb;
>
> gpio->gpiob_out |= (1 << offset);
> - if (value)
> - gpio->gpiob_val |= (1 << offset);
> - else
> - gpio->gpiob_val &= ~(1 << offset);
>
> mutex_lock(&vb->lock);

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/