Re: Abysmal HDD/USB write speed after sleep on a UEFI system

From: Bjorn Helgaas
Date: Tue Feb 26 2013 - 13:47:08 EST

On Mon, Feb 25, 2013 at 11:35 PM, Artem S. Tashkinov <t.artem@xxxxxxxxx> wrote:
> Feb 26, 2013 03:57:52 AM, Bjorn Helgaas wrote:
>>Where are we at with this, Artem? I assume it's still a problem.
> Yes, it is, Bjorn.
> In order to eliminate this problem I switched back to MBR yesterday, because
> so far I haven't received any instructions or guidance as to how I can debug
> it further. I'm absolutely sure USB write speed is just another manifestation of
> it so I decided not to debug USB specifically (it just doesn't make too much
> sense).
> What I see is that something terribly wrong is going on but if Linus has no ideas
> I, as an average Joe, don't have a slightest clue as to what I can do.
> The bug report with necessary, but seemingly useless information, can be
> found here:
> If anyone comes up with new ideas I can quickly try UEFI again now that I
> have two HDDs at my disposal (the old one is formatted as GPT, the new one is
> MBR).

The ideas I saw are:

1) Figure out whether it ever worked. If an older kernel worked
correctly and a newer one is broken, bisection is at least a
possibility. You mentioned that it did work before (Feb 12), but in
the past you never suspended twice in one boot session, whereas maybe
you did when seeing the problem?

2) Try the "setpci" to set the MSI address back to the original value
to see if it makes a difference (see my Feb 12 message).

3) Collect "lspci -vvv -xxxx" output to investigate the XHCI
Unsupported Request errors.

4) Use usbmon to collect traces before and after the suspend.

I googled around a bit looking for similar reports. I found lots of
suspend issues, mostly with Windows, but no leads yet. It looks like
the board has been around for a while, so you would think we'd have
some other reports of a problem this bad. But maybe it really is
related to UEFI and nobody really uses that yet?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at