Re: [PATCH v3 2/2] kexec: Use min_t to simplify logic

From: Zhang Yanfei
Date: Tue Feb 26 2013 - 03:57:57 EST


ä 2013å02æ26æ 16:53, Andrew Morton åé:
> On Tue, 26 Feb 2013 16:49:02 +0800 Zhang Yanfei <zhangyanfei@xxxxxxxxxxxxxx> wrote:
>
>>>> diff --git a/kernel/kexec.c b/kernel/kexec.c
>>> []
>>>> @@ -822,13 +822,9 @@ static int kimage_load_normal_segment(struct kimage *image,
>>> []
>>>> + mchunk = min_t(size_t, mbytes,
>>>> + (size_t)(PAGE_SIZE - (maddr & ~PAGE_MASK)));
>>>
>>> #define min_t(type, x, y) ({ \
>>> type __min1 = (x); \
>>> type __min2 = (y); \
>>> __min1 < __min2 ? __min1: __min2; })
>>>
>>>
>>>
>>
>> Hmm, from the definition, the cast is redundant.
>>
>> Maybe I misunderstood what Andrew meant in the mail related to v2:
>>
>> "The types of PAGE_SIZE and PAGE_MASK are vague - iirc they once had
>> different types on different architectures, so some form of casting is
>> unavoidable here."
>>
>> Andrew, could you please explain the casting you meant above?
>
> I mean that a cast (or min_t, which is a cast) will be needed.
> The code you have here casts the same thing two times, which isn't
> necessary.
>
>

Thanks.

Should I resend the patch again? After removing this redundant cast,
it is the same with v2.

Zhang
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/