Re: [PATCH 2/2] tg3: Use different macros for pci_chip_rev_idaccesses

From: Michael Chan
Date: Sat Feb 16 2013 - 17:10:03 EST


On Sat, 2013-02-16 at 13:20 -0800, Joe Perches wrote:
> Upper case macros for various chip attributes are slightly
> difficult to read and are a bit out of characterto the other
> tg3_<foo> attribute functions.
>
> Convert:
>
> GET_ASIC_REV(tp->pci_chip_rev_id) -> tg3_asic_rev(tp)
> GET_CHIP_REV(tp->pci_chip_rev_id) -> tg3_chip_rev(tp)
>
> Remove:
> GET_METAL_REV(tp->pci_chip_rev_id) -> tg3_metal_rev(tp) (unused)
>
> Add:
> tg3_chip_rev_id(tp) for tp->pci_chip_rev_id so access styles
> are similar to tg3_asic_rev and tg3_chip_rev.
>
> These macros are not converted to static inline functions
> because gcc (tested with 4.7.2) is currently unable to
> optimize the object code it produces the same way and code
> is otherwise larger.
>
> Signed-off-by: Joe Perches <joe@xxxxxxxxxxx>

Acked-by: Michael Chan <mchan@xxxxxxxxxxxx>


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/