Re: [PATCH] ia64: rename cache_show to topology_cache_show

From: Michal Hocko
Date: Sat Feb 16 2013 - 07:19:01 EST

On Fri 15-02-13 14:46:29, Andrew Morton wrote:
> On Fri, 15 Feb 2013 13:38:24 +0100
> Michal Hocko <mhocko@xxxxxxx> wrote:
> > Fenguang Wu has reported the following compile time issue
> > arch/ia64/kernel/topology.c:278:16: error: conflicting types for 'cache_show'
> > include/linux/slab.h:224:5: note: previous declaration of 'cache_show' was here
> >
> > which has been introduced by 749c5415 (memcg: aggregate memcg cache
> > values in slabinfo). Let's rename ia64 local function to prevent from
> > the name conflict.
> Confused. Tony fixed this ages ago?

Yes but it was after 3.7 so I didn't have it in my tree and I found out
only after I sent this email. Sorry about the confusion.
Michal Hocko
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at