Re: [PATCH] ia64: rename cache_show to topology_cache_show

From: Andrew Morton
Date: Fri Feb 15 2013 - 17:46:35 EST

On Fri, 15 Feb 2013 13:38:24 +0100
Michal Hocko <mhocko@xxxxxxx> wrote:

> Fenguang Wu has reported the following compile time issue
> arch/ia64/kernel/topology.c:278:16: error: conflicting types for 'cache_show'
> include/linux/slab.h:224:5: note: previous declaration of 'cache_show' was here
> which has been introduced by 749c5415 (memcg: aggregate memcg cache
> values in slabinfo). Let's rename ia64 local function to prevent from
> the name conflict.

Confused. Tony fixed this ages ago?

: commit 4fafc8c21487f6b5259d462e9bee98661a02390d
: Author: Tony Luck <tony.luck@xxxxxxxxx>
: Date: Wed Nov 7 15:51:04 2012 -0800
: [IA64] Resolve name space collision for cache_show()
: We have a local static function named rather generically
: "cache_show()". Changes in progress in the slab code want
: to use this same name globally - so they are adding their
: declaration to <linux/slab.h> which then causes the compiler
: to choke with:
: arch/ia64/kernel/topology.c:278: error: conflicting types for 'cache_show'
: Fix by adding an "ia64_" prefix to our local function.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at