Re: [ANNOUNCE] 3.8-rc6-nohz4

From: Ingo Molnar
Date: Thu Feb 07 2013 - 06:10:37 EST



* Steven Rostedt <rostedt@xxxxxxxxxxx> wrote:

> I'll reply to this as I come up with comments.
>
> First thing is, don't call it NO_HZ_FULL. A better name would
> be NO_HZ_CPU. I would like to reserve NO_HZ_FULL when we
> totally remove jiffies :-)

I don't think we want yet another config option named in a
weird way.

What we want instead is to just split NO_HZ up into its
conceptual parts:

CONFIG_NO_HZ_IDLE
CONFIG_NO_HZ_USER_SPACE
CONFIG_NO_HZ_KERNEL_SPACE

Where the current status quo is NO_HZ_IDLE=y, and Frederic is
about to introduce NO_HZ_USER_SPACE=y. When jiffies get removed
we get NO_HZ_KERNEL_SPACE=y.

The 'CONFIG_NO_HZ' meta-option, which we should leave for easy
configurability and for compatibility, should get us the
currently recommended default, which for the time being might
be:

CONFIG_NO_HZ_IDLE=y
# CONFIG_NO_HZ_USER_SPACE is disabled

Btw., you could add CONFIG_NO_HZ_KERNEL_SPACE right away, just
keep it false all the time. That would document our future plans
pretty well.

Once CONFIG_NO_HZ_USER_SPACE is proven problem-free, we might
default to:

CONFIG_NO_HZ_IDLE=y
CONFIG_NO_HZ_USER_SPACE=y

The goal is to have this in the distant future:

CONFIG_NO_HZ=y

CONFIG_NO_HZ_IDLE=y
CONFIG_NO_HZ_USER_SPACE=y
CONFIG_NO_HZ_KERNEL_SPACE=y

And eventually we might even be able to get rid of all the 3
variants, and only offer full-on/off.

Agreed?

Thanks,

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/