[PATCH 0/3] mm: rename confusing function names

From: Zhang Yanfei
Date: Tue Feb 05 2013 - 12:10:14 EST


Function nr_free_zone_pages, nr_free_buffer_pages and nr_free_pagecache_pages
are horribly badly named, they count present_pages - pages_high within zones
instead of free pages, so why not rename them to reasonable names, not cofusing
people.

patch2 and patch3 are based on patch1. So please apply patch1 first.

Zhang Yanfei (3):
mm: rename nr_free_zone_pages to nr_free_zone_high_pages
mm: rename nr_free_buffer_pages to nr_free_buffer_high_pages
mm: rename nr_free_pagecache_pages to nr_free_pagecache_high_pages

arch/ia64/mm/contig.c | 3 ++-
arch/ia64/mm/discontig.c | 3 ++-
drivers/mmc/card/mmc_test.c | 4 ++--
fs/buffer.c | 2 +-
fs/nfsd/nfs4state.c | 2 +-
fs/nfsd/nfssvc.c | 2 +-
include/linux/swap.h | 4 ++--
mm/huge_memory.c | 2 +-
mm/memory_hotplug.c | 4 ++--
mm/page-writeback.c | 2 +-
mm/page_alloc.c | 22 ++++++++++++----------
net/9p/trans_virtio.c | 2 +-
net/ipv4/tcp.c | 4 ++--
net/ipv4/udp.c | 2 +-
net/netfilter/ipvs/ip_vs_ctl.c | 2 +-
net/sctp/protocol.c | 2 +-
16 files changed, 33 insertions(+), 29 deletions(-)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/