[PATCH Bug fix 0/4] Bug fix for movablecore_map boot option.

From: Tang Chen
Date: Tue Jan 22 2013 - 06:47:17 EST


Hi Andrew,

patch1 ~ patch3 fix some problems of movablecore_map boot option.
And since the name "core" could be confused, patch4 rename this option
to movablemem_map.

All these patches are based on the latest -mm tree.
git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git akpm

Tang Chen (4):
Bug fix: Use CONFIG_HAVE_MEMBLOCK_NODE_MAP to protect movablecore_map
in memblock_overlaps_region().
Bug fix: Fix the doc format.
Bug fix: Remove the unused sanitize_zone_movable_limit() definition.
Rename movablecore_map to movablemem_map.

Documentation/kernel-parameters.txt | 8 +-
include/linux/memblock.h | 3 +-
include/linux/mm.h | 8 +-
mm/memblock.c | 42 +++++++++++-
mm/page_alloc.c | 116 +++++++++++++++++-----------------
5 files changed, 106 insertions(+), 71 deletions(-)

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/