3.7.0 does not detect Realtek network card automatically

From: Björn Christoph
Date: Tue Dec 18 2012 - 16:15:19 EST


I'm running Linux Ubuntu 12.0.4 with the following kernel:
linux 3.7.0-030700-generic #201212102335 SMP Tue Dec 11 04:36:24 UTC
2012 x86_64 x86_64 x86_64 GNU/Linux

Hardware: AMD A4-5300 CPU ; Gigabyte GA-F2A85X-D3H mainboard ; 4 Gb
RAM ; several Samsung and Seagate hard disks

I upgraded my system from a former AMD AM2+ mainboard with an AMD 240e
to the one above. Before I ran kernel 3.3.6 without issues.

Now, I upgraded to kernel 3.7.0 as my hardware is quite new.

Problem: If I start the system (it's a server without a GUI) and enter
my lvmcrypt password the system boots but it doesn't configure the
network. ifconfig just shows "local loopback". trying to bring up the
eth0 or eth1 states this one doesn't exist.

Workaround: Start the same kernel in recovery mode in Grub2 - choose
to "enable network". Afterwards, I still get the information like
"waiting for another 60 seconds to configure the network" and then
afterwards the message that not everything was configured. However, it
is - I then see "local loopback" and also eth0 with a proper IP.

You can find attached some kernel logs which might help in the analysis?

I also tried kernel 3.7.1 but that one doesn't work with the above
workaround - I never get a working network.

The driver for the Realtek network adapter of the mainboard I
recompiled with the latest available version as well.

Not sure what to do here. It's an Ubuntu kernel - should I take the
one from the kernel GIT, compile it and activate some debugging or
something to assist?


Attachment: boot_no_recovery_no_net.log
Description: Binary data

Attachment: boot_recovery_with_net.log
Description: Binary data