Re: [patch] [SCSI] mpt3sas: cut and paste bug storing trigger mpi

From: Dan Carpenter
Date: Fri Dec 07 2012 - 06:00:54 EST


On Fri, Dec 07, 2012 at 09:41:56AM +0100, Rolf Eike Beer wrote:
> > memset(&ioc->diag_trigger_mpi, 0,
> >- sizeof(struct SL_WH_EVENT_TRIGGERS_T));
> >+ sizeof(struct SL_WH_MPI_TRIGGERS_T));
> > memcpy(&ioc->diag_trigger_mpi, buf, sz);
> > if (ioc->diag_trigger_mpi.ValidEntries > NUM_VALID_ENTRIES)
> > ioc->diag_trigger_mpi.ValidEntries = NUM_VALID_ENTRIES;
>
> Then just use sizeof(ioc->diag_trigger_mpi), then it's irrelevant
> how that type is ever called.
>

Yeah, that's the way I would have prefered to write this as well.
It took me a while to verify that the intent here was not to clear
only part of the struct. Using sizeof(variable_name) instead of
sizeof(type) is more readable.

But then you get into the thing where the line before uses
sizeof(type)...

Oh well, I've sent both styles and the maintainer can choose. :)

regards,
dan carpenter

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/