Re: [PATCH v4 9/9] bug.h: Convert BUILD_BUG{,_ON} to useBUILD_BUG_ON_MSG

From: Borislav Petkov
Date: Tue Oct 30 2012 - 15:19:04 EST


On Sun, Oct 28, 2012 at 03:57:15PM -0500, danielfsantos@xxxxxxx wrote:
> Remove duplicate code by converting BUILD_BUG and BUILD_BUG_ON to just
> call BUILD_BUG_ON_MSG. This not only reduces source code bloat, but
> also prevents the possibility of code being changed for one macro and
> not for the other (which was previously the case for BUILD_BUG and
> BUILD_BUG_ON).
>
> Signed-off-by: Daniel Santos <daniel.santos@xxxxxxxxx>
> ---
> include/linux/bug.h | 17 +++--------------
> 1 files changed, 3 insertions(+), 14 deletions(-)
>
> diff --git a/include/linux/bug.h b/include/linux/bug.h
> index 3bc1ddf..b58ba51 100644
> --- a/include/linux/bug.h
> +++ b/include/linux/bug.h
> @@ -81,14 +81,8 @@ struct pt_regs;
> #ifndef __OPTIMIZE__
> #define BUILD_BUG_ON(condition) __compiletime_error_fallback(condition)
> #else
> -#define BUILD_BUG_ON(condition) \
> - do { \
> - extern void __build_bug_on_failed(void) \
> - __compiletime_error("BUILD_BUG_ON failed"); \
> - __compiletime_error_fallback(condition); \
> - if (condition) \
> - __build_bug_on_failed(); \
> - } while(0)
> +#define BUILD_BUG_ON(condition) \
> + BUILD_BUG_ON_MSG(condition, "BUILD_BUG_ON failed: " #condition)

Concatenating "condition" might not be very informative in all cases.
For example:

BUILD_BUG_ON(1);

Having __LINE__ is good enough IMHO.

Thanks.

--
Regards/Gruss,
Boris.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/