Re: [PATCH] ARM: zynq: move ttc timer code to drivers/clocksource

From: Michal Simek
Date: Tue Oct 30 2012 - 07:36:00 EST


On 10/29/2012 07:56 PM, Josh Cartwright wrote:
Suggested cleanup by Arnd Bergmann. Move the ttc timer.c code to
drivers/clocksource, and out of the mach-zynq directory.

The common.h (which only held the timer declaration) was renamed to
xilinx_ttc.h and moved into include/linux.

Signed-off-by: Josh Cartwright <josh.cartwright@xxxxxx>
Cc: Arnd Bergmann <arnd@xxxxxxxx>
---
arch/arm/mach-zynq/Makefile | 2 +-
arch/arm/mach-zynq/common.c | 2 +-
arch/arm/mach-zynq/common.h | 24 ----
arch/arm/mach-zynq/timer.c | 298 ---------------------------------------
drivers/clocksource/Makefile | 1 +
drivers/clocksource/xilinx_ttc.c | 297 ++++++++++++++++++++++++++++++++++++++
include/linux/xilinx_ttc.h | 24 ++++
7 files changed, 324 insertions(+), 324 deletions(-)
delete mode 100644 arch/arm/mach-zynq/common.h
delete mode 100644 arch/arm/mach-zynq/timer.c
create mode 100644 drivers/clocksource/xilinx_ttc.c
create mode 100644 include/linux/xilinx_ttc.h

Really?
If yes. shouldn't be there any better naming convention
especially for headers. linux/clocksource/xilinx_ttc.h.

Thanks,
Michal


--
Michal Simek, Ing. (M.Eng)
w: www.monstr.eu p: +42-0-721842854
Maintainer of Linux kernel 2.6 Microblaze Linux - http://www.monstr.eu/fdt/
Microblaze U-BOOT custodian
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/