[PATCHv3 0/6] lib/string: introduce kbasename helper

From: Andy Shevchenko
Date: Tue Oct 16 2012 - 07:49:03 EST


There are several places in kernel that duplicate code to get last part of the
pathname. This patchset introduces a helper and few fixes.

Since v2:
- fixed Cc list in the patch 6/6 ("trace: ...")
- update patch 3/6 ("rts_pstor: ...") to not hide const qualifier
- send patch 1/1 to all people involved to the series
- rebase against recent linux-next
Since v1:
- fix changelog of the patch 1 - we are doing basename(3) alike helper
- usb related patch temporary excluded from series (under discussion with Greg)

Andy Shevchenko (6):
lib/string: introduce helper to get base file name from given path
lib: dynamic_debug: reuse kbasename()
staging: rts_pstor: reuse kbasename()
mm: reuse kbasename() functionality
procfs: reuse kbasename() functionality
trace: reuse kbasename() functionality

drivers/staging/rts_pstor/trace.h | 24 ++++--------------------
fs/proc/proc_devtree.c | 7 ++-----
include/linux/string.h | 11 +++++++++++
kernel/trace/trace_uprobe.c | 8 ++++----
lib/dynamic_debug.c | 9 +--------
mm/memory.c | 8 +++-----
6 files changed, 25 insertions(+), 42 deletions(-)

--
1.7.10.4

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/