Re: [RFC PATCH v1 03/22] PCI: change PCI device management code tobetter follow device model

From: Bjorn Helgaas
Date: Tue Sep 11 2012 - 18:04:03 EST


On Tue, Aug 7, 2012 at 10:10 AM, Jiang Liu <liuj97@xxxxxxxxx> wrote:
> According to device model documentation, the way to add/remove device
> object should be symmetric.
>
> /**
> * device_del - delete device from system.
> * @dev: device.
> *
> * This is the first part of the device unregistration
> * sequence. This removes the device from the lists we control
> * from here, has it removed from the other driver model
> * subsystems it was added to in device_add(), and removes it
> * from the kobject hierarchy.
> *
> * NOTE: this should be called manually _iff_ device_add() was
> * also called manually.
> */
>
> The rule here is to either use
> 1) device_register()/device_unregister()
> or
> 2) device_initialize()/device_add()/device_del()/put_device().
>
> So change PCI core to follow the rule and get rid of the redundant
> pci_dev_get()/pci_dev_put() pair.

Seems OK to me.

> Signed-off-by: Jiang Liu <liuj97@xxxxxxxxx>
> ---
> drivers/pci/probe.c | 1 -
> drivers/pci/remove.c | 4 ++--
> 2 files changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
> index 0840409..dacca26 100644
> --- a/drivers/pci/probe.c
> +++ b/drivers/pci/probe.c
> @@ -1294,7 +1294,6 @@ void pci_device_add(struct pci_dev *dev, struct pci_bus *bus)
> {
> device_initialize(&dev->dev);
> dev->dev.release = pci_release_dev;
> - pci_dev_get(dev);
>
> dev->dev.dma_mask = &dev->dma_mask;
> dev->dev.dma_parms = &dev->dma_parms;
> diff --git a/drivers/pci/remove.c b/drivers/pci/remove.c
> index 33b6318..b9ac765 100644
> --- a/drivers/pci/remove.c
> +++ b/drivers/pci/remove.c
> @@ -22,7 +22,7 @@ static void pci_stop_dev(struct pci_dev *dev)
> if (dev->is_added) {
> pci_proc_detach_device(dev);
> pci_remove_sysfs_dev_files(dev);
> - device_unregister(&dev->dev);
> + device_del(&dev->dev);
> dev->is_added = 0;
> }
>
> @@ -40,7 +40,7 @@ static void pci_destroy_dev(struct pci_dev *dev)
> up_write(&pci_bus_sem);
>
> pci_free_resources(dev);
> - pci_dev_put(dev);
> + put_device(&dev->dev);
> }
>
> /**
> --
> 1.7.9.5
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/