+ id = irq_domain_add_linear(np, num,
+ &ioapic_irq_domain_ops,
+ (void *)ioapic_num);
This fits on two lines instead of three.
+ pr_err("Error creating mapping for the "
+ "remaining irqs: %d\n", ret);
There's an extra space between "remaining" and "irqs". Also other places
use the spelling IRQ and IRQs respectively in strings, so it may be nice
to stay consistent.
Besides the above nitpicks:
Reviewed-by: Thierry Reding<thierry.reding@xxxxxxxxxxxxxxxxx>
Tested-by: Thierry Reding<thierry.reding@xxxxxxxxxxxxxxxxx>
On another note, I saw that you've used the "intel,ce4100" prefix in
various places and I wonder if it would be useful to replace them with
something more generic like "intel,hpet", "intel,lapic" and
"intel,ioapic" respectively. The hardware that I use is based on an Atom
N450 and works with the current code, so it really isn't ce4100-
specific.
Thierry