Re: [patch v2] hugetlb: correct page offset index for sharing pmd

From: Michal Hocko
Date: Mon Aug 06 2012 - 11:54:29 EST


On Mon 06-08-12 21:37:45, Hillf Danton wrote:
> On Mon, Aug 6, 2012 at 9:24 PM, Michal Hocko <mhocko@xxxxxxx> wrote:
> > On Sat 04-08-12 14:08:31, Hillf Danton wrote:
> >> The computation of page offset index is incorrect to be used in scanning
> >> prio tree, as huge page offset is required, and is fixed with well
> >> defined routine.
> >>
> >> Changes from v1
> >> o s/linear_page_index/linear_hugepage_index/ for clearer code
> >> o hp_idx variable added for less change
> >>
> >>
> >> Signed-off-by: Hillf Danton <dhillf@xxxxxxxxx>
> >> ---
> >>
> >> --- a/arch/x86/mm/hugetlbpage.c Fri Aug 3 20:34:58 2012
> >> +++ b/arch/x86/mm/hugetlbpage.c Fri Aug 3 20:40:16 2012
> >> @@ -62,6 +62,7 @@ static void huge_pmd_share(struct mm_str
> >> {
> >> struct vm_area_struct *vma = find_vma(mm, addr);
> >> struct address_space *mapping = vma->vm_file->f_mapping;
> >> + pgoff_t hp_idx;
> >> pgoff_t idx = ((addr - vma->vm_start) >> PAGE_SHIFT) +
> >> vma->vm_pgoff;
> >
> > So we have two indexes now. That is just plain ugly!
> >
>
> Two indexes result in less code change here and no change
> in page_table_shareable. Plus linear_hugepage_index tells
> clearly readers that hp_idx and idx are different.

Why do you think they are different? It's the very same thing AFAICS.
It's just that page_table_shareable fix the index silently by saddr &
PUD_MASK.
--
Michal Hocko
SUSE Labs
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/