Re: [vmw_vmci 11/11] Apply the header code to make VMCI build

From: Sam Ravnborg
Date: Fri Jul 27 2012 - 15:53:27 EST


> > > +
> > > +#define CAN_BLOCK(_f) (!((_f) & VMCI_QPFLAG_NONBLOCK))
> > > +#define QP_PINNED(_f) ((_f) & VMCI_QPFLAG_PINNED)
> >
> > Looks like poor obscufation.
> > Use a statis inline function if you need a helper for this.
>
> These definitions are intended more as a helper to make reading the code easier. IMHO ts a lot easier to read
>
> if (CAN_BLOCK(flags))
>
> compared to
>
> if (!(flags & VMCI_QPFLAG_NONBLOCK))
>
> Wouldn't you agree? I'm not sure something this simple warrants a static inline
> function but I don't see any harm in converting it over to that.

I would put it the other way around. I cannot see that such simple stuff warrants a #define.
A static inline is (almost) always preferable to hide code in a macro.

For once you get better type-checks.
And semantics are also much simpler. With a macro you can do so many silly things.

Sam
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/