Re: [PATCH] led: use correct name for /sys/devices/virtual/leds/entries

From: Lars-Peter Clausen
Date: Wed Jul 18 2012 - 12:57:06 EST


On 07/18/2012 06:49 PM, olaf@xxxxxxxxx wrote:
> From: Olaf Hering <olaf@xxxxxxxxx>
>
> Follow naming according to Documentation/leds/leds-class.txt:
> LED Device Naming
> Is currently of the form:
> "devicename:colour:function"
>
> Reported during openSuSE 11.1 testing.
> https://bugzilla.novell.com/show_bug.cgi?&id=468350
>
> Signed-off-by: Olaf Hering <olaf@xxxxxxxxx>
>
> diff --git a/drivers/leds/ledtrig-default-on.c b/drivers/leds/ledtrig-default-on.c
> index a4ef54b..2efdd30 100644
> --- a/drivers/leds/ledtrig-default-on.c
> +++ b/drivers/leds/ledtrig-default-on.c
> @@ -23,7 +23,7 @@ static void defon_trig_activate(struct led_classdev *led_cdev)
> }
>
> static struct led_trigger defon_led_trigger = {
> - .name = "default-on",
> + .name = "default::on",
> .activate = defon_trig_activate,
> };
>

That's a LED trigger, not a LED. So the LED naming convention doesn't apply
here and it does not even make sense to try to apply it. Also the patch
breaks all users of the default-on trigger.

- Lars
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/