From: Michael Kerrisk (man-pages)
Date: Tue Jul 17 2012 - 09:54:50 EST

On Tue, Jul 17, 2012 at 3:46 PM, Serge E. Hallyn <serge@xxxxxxxxxx> wrote:
> Quoting Michael Kerrisk (mtk.manpages@xxxxxxxxx):
>> Rafael,
>> As discussed in
>> the capability introduced in 4d7e30d98939a0340022ccd49325a3d70f7e0238
>> to govern EPOLLWAKEUP seems misnamed: this capability is about governing
>> the ability to suspend the system, not using a particular API flag
>> (EPOLLWAKEUP). We should make the name of the capability more general
>> to encourage reuse in related cases. (Whether or not this capability
>> should also be used to govern the use of /sys/power/wake_lock is a
>> question that needs to be separately resolved.)
>> This patch renames the capability to CAP_BLOCK_SUSPEND. In order to ensure
>> that the old capability name doesn't make it out into the wild, could you
>> please apply and push up the tree to ensure that it is incorporated
>> for the 3.5 release.
>> Thanks,
>> Michael
>> Signed-off-by: Michael Kerrisk <mtk.manpages@xxxxxxxxx>
> I definately like that name better, thanks. Don't know if renaming it
> without an alias could cause trouble for some bleeding edge userspaces?
> Would it be worth keeping the
> #define CAP_EPOLLWAKEUP 36
> line? If this is deemed early enough I do prefer not to complicate with
> a duplicate name.

Maybe I'm too ignorant. Are there userspaces that bleed with the -rc
series? I'd have thought this renaming would be a fairly safe change
at this point.

> Acked-by: Serge Hallyn <serge.hallyn@xxxxxxxxxxxxx>



Michael Kerrisk
Linux man-pages maintainer;
Author of "The Linux Programming Interface";
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at