Re: [PATCH v4 02/13] libata: bind the Linux device tree to the ACPIdevice tree

From: Lin Ming
Date: Wed Jun 13 2012 - 04:03:33 EST


On Mon, May 28, 2012 at 5:51 PM, Alan Cox <alan@xxxxxxxxxxxxxxxxxxx> wrote:
>> +static int is_pci_ata(struct device *dev)
>> +{
>> +     struct pci_dev *pdev;
>> +
>> +     if (!is_pci_dev(dev))
>> +             return 0;
>> +
>> +     pdev = to_pci_dev(dev);
>> +
>> +     if ((pdev->class >> 8) != PCI_CLASS_STORAGE_SATA &&
>> +         (pdev->class >> 8) != PCI_CLASS_STORAGE_IDE)
>> +             return 0;
>
> This needs a better name. It doesn't check if a device is PCI ATA or
> anything of the sort, it checks if its probably a device in compatibility
> mode. A lot of controllers will in fact report RAID class or similar in
> native mode.

How about compat_pci_ata?

>
> Alan
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/