Re: [PATCH 3/4] HID: roccat: Renamed roccat_common functions toroccat_common2

From: Jiri Kosina
Date: Fri Jun 08 2012 - 04:29:34 EST


On Sun, 20 May 2012, Stefan Achatz wrote:

> Did this to illustrate my understanding of the firmware generations:
> Valo and Kone were 1st generation
> Arvo was externaly developed and lies in the middle
> All others until now are considered 2nd generation
>
> Signed-off-by: Stefan Achatz <erazor_de@xxxxxxxxxxxxxxxxxxxxx>
> ---
> drivers/hid/hid-roccat-arvo.c | 16 ++++++++--------
> drivers/hid/hid-roccat-common.c | 34 +++++++++++++++++-----------------
> drivers/hid/hid-roccat-common.h | 10 +++++-----
> drivers/hid/hid-roccat-isku.c | 6 +++---
> drivers/hid/hid-roccat-koneplus.c | 24 ++++++++++++------------
> drivers/hid/hid-roccat-kovaplus.c | 20 ++++++++++----------
> drivers/hid/hid-roccat-pyra.c | 20 ++++++++++----------
> drivers/hid/hid-roccat-savu.c | 4 ++--
> 8 files changed, 67 insertions(+), 67 deletions(-)
>
> diff --git a/drivers/hid/hid-roccat-arvo.c b/drivers/hid/hid-roccat-arvo.c
> index 093bfad..327f9b8 100644
> --- a/drivers/hid/hid-roccat-arvo.c
> +++ b/drivers/hid/hid-roccat-arvo.c
> @@ -39,7 +39,7 @@ static ssize_t arvo_sysfs_show_mode_key(struct device *dev,
> int retval;
>
> mutex_lock(&arvo->arvo_lock);
> - retval = roccat_common_receive(usb_dev, ARVO_COMMAND_MODE_KEY,
> + retval = roccat_common2_receive(usb_dev, ARVO_COMMAND_MODE_KEY,

Could you please give it some more descriptive name, that will clearly
illustrate that the differentiating factor is the firmware
version/generation?

Thanks,

--
Jiri Kosina
SUSE Labs
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/