[RFC 0/3] Extend type checking macros

From: Sasha Levin
Date: Sat Apr 14 2012 - 15:15:48 EST


Commit e3831ed ("sched: Fix incorrect usage of for_each_cpu_mask() in
select_fallback_rq()") fixes a very non obvious bug in select_fallback_rq()
which was caused by passing 'struct cpumask' instead of 'struct cpumask *'
to a macro in include/linux/cpumask.h

This bug was quite a pain to debug since it doesn't raise any warnings or
erros during compilation, and the assumption of the kernel hackers who try
to fix a bug is that if the compiler didn't complain, they passed the right
types to functions.

This series of patches adds some more type checking macros to the forgotten
include/linux/typecheck.h, it modified for_each_cpu_mask() to use those
macros to trigger a warning when needed (this is a nice demonstration of how
the bug mentioned before would have been visible with these checks), and
modifies min()/max() and friend to use these macros as well to show their
value in reducing duplicate code and improving readability.

Sasha Levin (3):
typecheck: extend typecheck.h with more useful typechecking macros
sched: add type checks to for_each_cpu_mask()
kernel.h: use new typechecking macros in min()/max() and friends

include/linux/cpumask.h | 4 ++-
include/linux/kernel.h | 47 ++++++++++++++------------------------------
include/linux/typecheck.h | 42 ++++++++++++++++++++++++++++++++-------
3 files changed, 52 insertions(+), 41 deletions(-)

--
1.7.8.5

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/