Re: [PATCH 03/13] KVM: MMU: split FNAME(prefetch_invalid_gpte)

From: Xiao Guangrong
Date: Thu Mar 29 2012 - 23:52:09 EST


On 03/29/2012 09:00 PM, Avi Kivity wrote:

> On 03/29/2012 11:22 AM, Xiao Guangrong wrote:
>> Split FNAME(prefetch_invalid_gpte) to check gpte independently which will
>> be used in the later patch
>>
>>
>> -static bool FNAME(prefetch_invalid_gpte)(struct kvm_vcpu *vcpu,
>> - struct kvm_mmu_page *sp, u64 *spte,
>> - pt_element_t gpte)
>> +static bool FNAME(invalid_gpte)(struct kvm_vcpu *vcpu, pt_element_t gpte)
>> {
>> if (is_rsvd_bits_set(&vcpu->arch.mmu, gpte, PT_PAGE_TABLE_LEVEL))
>> - goto no_present;
>> + return true;
>>
>> if (!is_present_gpte(gpte))
>> - goto no_present;
>> + return true;
>>
>> if (!(gpte & PT_ACCESSED_MASK))
>> - goto no_present;
>> + return true;
>>
>> return false;
>
> A comment (or a name change) is needed to indicate that we're not
> checking for an invalid gpte, just invalid for caching in an spte.


Yes, i will change the name to FNAME(is_cacheable_gpte) and and some
comments.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/