Re: [PATCH 3/7 v2] mm: rework __isolate_lru_page() file/anonfilter

From: Hugh Dickins
Date: Thu Mar 08 2012 - 21:07:41 EST


On Thu, 8 Mar 2012, KAMEZAWA Hiroyuki wrote:
> On Tue, 6 Mar 2012 19:22:21 -0800 (PST)
> Hugh Dickins <hughd@xxxxxxxxxx> wrote:
> >
> > What does the compiler say (4.5.1 here, OPTIMIZE_FOR_SIZE off)?
> > text data bss dec hex filename
> > 17723 113 17 17853 45bd vmscan.o.0
> > 17671 113 17 17801 4589 vmscan.o.1
> > 17803 113 17 17933 460d vmscan.o.2
> >
> > That suggests that your v2 is the worst and your v1 the best.
> > Kame, can I persuade you to let the compiler decide on this?
> >
>
> Hmm. How about Costa' proposal ? as
>
> int tmp_var = PageActive(page) ? ISOLATE_ACTIVE : ISOLATE_INACTIVE
> if (!(mode & tmp_var))
> ret;

Yes, that would have been a good compromise (given a better name
than "tmp_var"!), I didn't realize that one was acceptable to you.

But I see that Konstantin has been inspired by our disagreement to a
more creative solution.

I like very much the look of what he's come up with, but I'm still
puzzling over why it barely makes any improvement to __isolate_lru_page():
seems significantly inferior (in code size terms) to his original (which
I imagine Glauber's compromise would be equivalent to).

At some point I ought to give up on niggling about this,
but I haven't quite got there yet.

Hugh
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/