Re: [RFC PATCH 5/5 single-thread-version] implement per-domainsingle-thread state machine call_srcu()

From: Peter Zijlstra
Date: Thu Mar 08 2012 - 08:05:18 EST


On Wed, 2012-03-07 at 11:54 +0800, Lai Jiangshan wrote:
> +static void srcu_advance_batches(struct srcu_struct *sp)
> +{
> + int idx = 1 - (sp->completed & 0x1UL);
> +
> + /*
> + * SRCU read-side critical sections are normally short, so check
> + * twice after a flip.
> + */
> + if (!rcu_batch_empty(&sp->batch_check1) ||
> + !rcu_batch_empty(&sp->batch_check0)) {
> + if (try_check_zero(sp, idx, 1)) {
> + rcu_batch_move(&sp->batch_done, &sp->batch_check1);
> + rcu_batch_move(&sp->batch_check1, &sp->batch_check0);
> + if (!rcu_batch_empty(&sp->batch_check1)) {
> + srcu_flip(sp);
> + if (try_check_zero(sp, 1 - idx, 2)) {
> + rcu_batch_move(&sp->batch_done,
> + &sp->batch_check1);
> + }
> + }
> + }
> + }
> +}

static void srcu_advance_batches(struct srcu_struct *sp)
{
int idx = 1 - (sp->completed & 1);

if (rcu_batch_empty(&sp->batch_check0) &&
rcu_batch_empty(&sp->batch_check1))
return;

if (!try_check_zero(sp, idx, 1))
return;

rcu_batch_move(&sp->batch_done, &sp->batch_check1);
rcu_batch_move(&sp->batch_check1, &sp->batch_check0);

if (rcu_batch_empty(&sp->batch_check1))
return;

srcu_flip(sp);

if (!try_check_zero(sp, idx^1, 2))
return;

rcu_batch_move(&sp->batch_done, &sp->batch_check1);
}

Seems like a more readable version.. do check I didn't mess up the logic
though.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/