Re: Question about error from xhci-hcd

From: Andiry Xu
Date: Tue Feb 07 2012 - 04:52:20 EST

On 02/07/2012 01:47 PM, Richard Farina wrote:
> I apologize but I am having the same issue reported in this thread in
> December
> [ 5077.573181] xhci_hcd 0000:0a:00.0: ERROR no room on ep ring
> I saw no resolution on this issue so I figured I'd step up and see if
> you needed an active tester who could reproduce the issue.
> I am running Gentoo with a 3.2.2 kernel. I am able to run any kernel
> version you need, including random git trees and custom patches. If you
> have not solved this yet, please allow me to be your test monkey. If you
> have solved this already then sorry for harming the signal to noise
> ratio, I could not a find a later message then the one below.

You can try andiry-ring-expansion branch on Sarah's xhci git tree. It
contains bugs and I'm trying to fix that, but you can have a try.


> On 12/28/2011 10:30 PM, Andiry Xu wrote:
>> That's the error I want to see, but I didn't find it in the dmesg you
>> posted. is it wrapped?
>> Anyway, please post the full dmesg with no room on ring error and the
>> dump of the ep ring and event ring (so the xhci_debug_ring() is
>> triggered in the patch), so we can see if the ring is mangled or there
>> is just too many transfers.
>> Another thing you can try is the andiry-ring-expansion branch on Sarah's
>> xhci git tree, check if there is still no room on ring error.
> No, the ring is not wrapped. I seems that my anti-spam mechanism kicked
> in too
> soon. or the run stopped too soon.
> I'll have the OP do another run and see if we can get the right
> information.
> Larry
> --

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at