Re: [PATCH] USB: debugging code shouldn't alter control flow

From: Keith Packard
Date: Sat Feb 04 2012 - 10:49:20 EST


On Thu, 2 Feb 2012 15:38:14 -0500 (EST), Alan Stern <stern@xxxxxxxxxxxxxxxxxxx> wrote:

> - urb->transfer_flags &= allowed;
> + allowed &= urb->transfer_flags;

Minor bikeshed here, but 'allowed' is not the right name for the value
at this point; perhaps just

/* warn if submitter gave bogus flags */
if ((urb->transfer_flags & allowed) != urb->transfer_flags)

might be better?

Otherwise, this looks nice to me.

Acked-by: Keith Packard <keithp@xxxxxxxxxx>

--
keith.packard@xxxxxxxxx

Attachment: pgp00000.pgp
Description: PGP signature