Re: [RFC] killing boilerplate checks in ->link/->mkdir/->rename

From: Andreas Dilger
Date: Sat Feb 04 2012 - 02:43:27 EST


On 2012-02-03, at 10:03 AM, Al Viro wrote:
> On Fri, Feb 03, 2012 at 01:25:26AM -0700, Andreas Dilger wrote:
>> On 2012-02-02, at 2:24 PM, Al Viro wrote:
>>> FWIW, there's something we really should've done a long time ago: putting
>>> that limit into sb->s_max_links. With 0 meaning "leave all checks to
>>> ->link/->mkdir/->rename". Something like the following would make a
>>> reasonable start - just the conversion of obvious cases. As the next
>>> step I'd probably initialize it as ~0U instead of 0 and let the filesystems
>>> that want something trickier (reiserfs, ext4, gfs2, ocfs2) explicitly set
>>> it to 0 in their foo_fill_super(). That would take care of a bunch of cases
>>> where we forgot to do those checks (ubifs, hfsplus, jffs2, ramfs, etc.) and
>>> it's probably a saner default anyway.
>>
>> This would also give userspace some hope of pathconf(path, _PC_LINK_MAX)
>> returning the actual value from the filesystem, instead of hard-coding
>> this into glibc itself based on the statfs-returned f_type magic value.
>
> *snort*
>
> Even skipping the standard flame about pathconf() as an API, this will
> not work.
> * we have filesystems that do not allow link creation at all and
> do keep track of subdirectories count in i_nlink of directories. What
> would you have them store? As it is, ~0U works just fine, but pathconf()
> users won't be happy with it.
> * we have filesystems that allow unlimited subdirectories, while
> limiting the number of links to non-directories; ->s_max_links == 0 will
> work just fine, but won't make pathconf() happy.
> * we have filesystems that have more complex rules re links to
> non-directory (see mail from Chris in this thread). What would you have
> pathconf() do?

No comment on how good an API pathconf() is, but getting a per-filesystem
value from the kernel has to be better than a hard-coded value coded in a
library in userspace.

Cheers, Andreas





--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/