Re: [PATCH 01/10] cgroups: add res_counter_write_u64() API

From: Frederic Weisbecker
Date: Thu Feb 02 2012 - 08:56:17 EST


On Thu, Feb 02, 2012 at 02:33:22PM +0200, Kirill A. Shutemov wrote:
> On Wed, Feb 01, 2012 at 04:37:41AM +0100, Frederic Weisbecker wrote:
> > +#if BITS_PER_LONG == 32
> > +void res_counter_write_u64(struct res_counter *counter, int member, u64 val)
> > +{
> > + unsigned long long *target;
> > + unsigned long flags;
> > +
> > + spin_lock_irqsave(&counter->lock, flags);
> > + target = res_counter_member(counter, member);
> > + *target = val;
>
> Nitpick: What's the point to have temporary variable here?

Dunno, just a matter of habit, I use to avoid expressions
like *func(foo) = bar. It looks less readable to me but
perhaps it's because I'm not used to it.

>
> > + spin_unlock_irqrestore(&counter->lock, flags);
> > +}
> > +#else
> > +void res_counter_write_u64(struct res_counter *counter, int member, u64 val)
> > +{
> > + unsigned long long *target;
> > +
> > + target = res_counter_member(counter, member);
> > + *target = val;
>
> Ditto.
>
> > +}
> > +#endif
>
> --
> Kirill A. Shutemov
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/