Re: [PATCH 2/7] ftrace: Add enable/disable ftrace_ops controlinterface

From: Frederic Weisbecker
Date: Fri Jan 27 2012 - 12:02:10 EST


On Fri, Jan 27, 2012 at 05:54:16PM +0100, Jiri Olsa wrote:
> On Fri, Jan 27, 2012 at 05:40:49PM +0100, Frederic Weisbecker wrote:
> > On Fri, Jan 27, 2012 at 11:37:14AM +0100, Jiri Olsa wrote:
> > > On Thu, Jan 26, 2012 at 03:37:29AM +0100, Frederic Weisbecker wrote:
> > > > On Wed, Jan 25, 2012 at 06:13:41PM -0500, Steven Rostedt wrote:
> > > > > On Fri, 2012-01-20 at 18:02 +0100, Frederic Weisbecker wrote:
> > > > > >
> > > > > > > +/**
> > > > > > > + * ftrace_function_enable - enable controlled ftrace_ops on given cpu
> > > > > > > + *
> > > > > > > + * This function enables tracing on given cpu by decreasing
> > > > > > > + * the per cpu control variable.
> > > > > > > + * It must be called with preemption disabled and only on
> > > > > > > + * ftrace_ops registered with FTRACE_OPS_FL_CONTROL.
> > > > > > > + */
> > > > > > > +static inline void ftrace_function_enable(struct ftrace_ops *ops, int cpu)
> > > > > > > +{
> > > > > > > + atomic_t *disabled;
> > > > > > > +
> > > > > > > + if (WARN_ON_ONCE(!(ops->flags & FTRACE_OPS_FL_CONTROL) ||
> > > > > > > + !preempt_count()))
> > > > > > > + return;
> > > > > > > +
> > > > > > > + disabled = per_cpu_ptr(ops->disabled, cpu);
> > > > > > > + atomic_dec(disabled);
> > > > > > > +}
> > > > > >
> > > > > > As you're using this for the local CPU exclusively, I suggest you rather
> > > > > > rename it to "ftrace_function_{dis,en}able_cpu(struct ftrace_ops *ops)"
> > > > >
> > > > > I wonder if "ftrace_function_local_{dis,en}able(ops)" would be better?
> > > > > That would match something like local_irq_disable/enable.
> > > >
> > > > Good idea.
> > > >
> > > > >
> > > > > > and use __get_cpu_var() that does the preempt check for you.
> > >
> > > I haven't found preempt check this_cpu_ptr path.. not sure I missed it..
> > > so I'm keeping the implicit preemt check.
> >
> > #ifdef CONFIG_DEBUG_PREEMPT
> > #define my_cpu_offset per_cpu_offset(smp_processor_id())
> > #else
> > #define my_cpu_offset __my_cpu_offset
> > #endif
> >
> > #ifdef CONFIG_DEBUG_PREEMPT
> > #define this_cpu_ptr(ptr) SHIFT_PERCPU_PTR(ptr, my_cpu_offset)
> > #else
> > #define this_cpu_ptr(ptr) __this_cpu_ptr(ptr)
> > #endif
> >
> > And smp_processor_id() has a preemption check.
>
> yay.. ok :) so this one is triggered only if there's CONFIG_DEBUG_PREEMPT
> option enabled.. seems to me it'd better to keep the implicit check anyway.
>
> jirka


This is a debugging option deemed to lower runtime debugging checks in
production.

Is there a good reason to keep the check on every case?
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/