Re: [PATCH 1/2] Staging; bcm/CmHost.c: Style cleanup

From: Dan Carpenter
Date: Wed Jan 25 2012 - 01:25:51 EST


This is probably going to need to be redone on top of the other bcm
cleanup patches anyway.

On Tue, Jan 24, 2012 at 11:46:31PM +0100, Jesper Juhl wrote:
> + pstClassifierEntry->ucDestPortRangeLength
> + = psfCSType->cCPacketClassificationRule.u8ProtocolDestPortRangeLength/4;

Put the equals on the first line when you break something up like
this. Also the real fix here is to choose shorter and better names
than "cCPacketClassificationRule.u8ProtocolDestPortRangeLength".

If you're breaking up a condition normally the && or || go on the
first line as well.
if (foo &&
bar &&
baz) { ...

Although that's not in CodingStyle so it's not a "redo the patch"
situation.

regards,
dan carpenter

Attachment: signature.asc
Description: Digital signature