Re: [RFC] fs, proc: Introduce /proc/<pid>/task/<tid>/children entryv6

From: Cyrill Gorcunov
Date: Thu Jan 19 2012 - 09:47:10 EST


On Thu, Jan 19, 2012 at 03:10:51PM +0100, Oleg Nesterov wrote:
> On 01/18, Cyrill Gorcunov wrote:
> >
> > I suppose it might be something like below. I've updated comment and
> > quoted your comment there just I wont forget this next time I'll be
> > reading the source. Thanks!
>
> I believe the patrch is correct.
>
> But... Cyrill, I am wondering how much will you hate me if I make
> yet another attempt to delay this patch.
>

I'm ready to do any iterations until patch become correct. It's better
to spend some time now than later.

> > +static int children_seq_open(struct inode *inode, struct file *file)
> > +{
> > + struct proc_pid_children_iter *iter = NULL;
> > + struct task_struct *task = NULL;
> > + int ret = 0;
> > +
> > + task = get_proc_task(inode);
> > + if (!task) {
> > + ret = -ENOENT;
> > + goto err;
> > + }
>
> For what??
>
> > + if (!ret) {
> > + struct seq_file *m = file->private_data;
> > + m->private = iter;
> > +
> > + iter->pid_start = get_pid(task_pid(task));
>
> This is what we need, right? So can't we remove this "task_struct *task"
> and simply do
>
> iter->pid_start = get_ppid(proc_pid(inode));
>

Yeah, this one will be cleaner. Thanks!

> ?
>
> And while this is absolutely cosmetic probably ->parent_pid is
> a bit better name, but this is up to you.
>

Yeah, I'll change the name, I liked this one more.

Cyrill
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/